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Benefits of Using OBS Studio 

As classes have moved entirely to online learning for Fall 2020 and potentially beyond, 

there is a dire need for more engaging virtual education services. While presenting lecture slides 

with a voiceover is a quick and easy alternative, surveys have shown that the lack of human 

connection leads to decreased engagement and knowledge retention. With Zoom live lectures, 

the limitations of the platform as well as with camera and audio quality leave much to be desired. 

However, the effectiveness of live meeting software such as Zoom or Microsoft Teams can be 

greatly boosted with the use of OBS.  

OBS Studio is a free open source software that serves as an intermediary between the 

presenter and whatever streaming service you are using. The software has numerous capabilities 

and features that can allow for lecture videos to be more active, engaging and streamlined. OBS 

uses a system of scenes that act as the hubs for the different inputs that you may be using, such 

as external cameras, third-party software, screen captures, and more. These scenes can be set up 

in advance and changed with the simple click of a pre-ordained key to allow for seamless 

transitions and allow the presenter to focus on the lecture content. Combined with the technology 

of the LightBoard, OBS can provide a truly engaging online educational experience. 

Downloading OBS Studio and Plugins 

To download OBS Studio: 

1. Go to www.obsproject.com 

2. Select either Windows or MacOS 10.13+ depending on your computer and what operating 

system it uses.  

3. Wait for the download to finish and install the program with default settings. 

OBS Virtual Camera and Audio Cables 

The virtual camera system in OBS allows the system to capture your window from OBS and connect 

it to whatever streaming platform you are using. Think of it like a webcam: instead of Zoom 

showing your face from your laptop’s actual camera, the virtual camera and captures output video 

http://www.obsproject.com/
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from OBS (where your webcam will be hooked up as well) and displays that in Zoom. This is 

basically how Zoom and OBS communicate with each other. Similarly, the virtual audio cables can 

be set up so the voice that your laptop captures and feeds into OBS can be heard by your students 

through Zoom (or whatever streaming platform you use).  

NOTE: Virtual Cam only works with Windows OS. If you have MacOS, look at Syphon Client below. 

To download OBS Virtual Camera: 

1. Go to https://github.com/Fenrirthviti/obs-virtual-cam/releases. 

2. Under “OBS-VirtualCam 2.0.5”, there should be a link that says “obs-virtualcam-2.0.5-Windows-

installer.exe”. Click on this link and let the download finish.  

3. After it has finished downloading, open the file and install the program.  

4. When it asks you how many cameras you want, open the dropdown menu and select 4, which is 

maximum number of cameras you can have. In reality, you will probably only need 1 camera, but 

it is useful to have the extra tools should a need arise in the future.  

5. Finish the installation. 

Syphon Client Plugin 

The virtual camera only works with Windows operating systems, so if you run a MacOS computer 

you will need to use Syphon Client. It works much the same as a virtual camera.   

To Download Syphon: 

1. Go to http://syphon.v002.info/#license. 

2. Scroll down to Developer SDK. Under that heading, there is an orange link that says “download”. 

Press that link and allow the download to finish. 

3. Install the program with the default developer settings.  

 

 

 

https://github.com/Fenrirthviti/obs-virtual-cam/releases
http://syphon.v002.info/#license
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Understanding OBS User Interface 

OBS Studio looks daunting at first glance but it is very easy to learn how to use and navigate. As 

mentioned before, OBS uses something called Scenes. These are like the different slides in a 

PowerPoint presentation that you can show on screen during a lecture. A scene is comprised of 

typically 1 or more Sources. These can be video or audio input sources that you use to connect 

your webcam to OBS or connecting your Virtual Cam to Zoom, but they can also be more complex. 

You can add simple texts or images onto your presenter view, you can use display captures to 

show live polling or chat windows, or even use a virtual green screen to show your slides on the 

same plane as your face. The possibilities are endless with OBS. 

Launching OBS for the First Time 

When you launch the program, you will see something like the Figure 1 below. There will be 2 

large black windows and a variety of settings surrounding them (if you do not see this, click Studio 

Mode on the control panel on the left side). The black box on the left of your screen is the Preview 

Mode. This is where you can see what scenes you are going to be presenting next, and this is 

where you can edit the size and text information in your scenes as well.  

Figure 1 
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Program View (on the right) is what the audience sees when you run OBS. Having both program 

and preview modes visible side by side allows you to understand what exactly is being shown and 

what will be shown next, offering smooth and clean transitions between different scenes.  

Scenes in OBS can be added at the bottom left hand corner, as shown in Figure 2 below. The scenes 

can be organized and all set up before a meeting starts so your presentation unencumbered by 

OBS’s settings during the live lectures. To add or remove a scene press the “+” or the “-“ buttons. 

You can also hide certain sources and also lock them to prevent them from moving around while 

you edit your scene. You can rearrange them as well so that certain sources appear in front of 

other sources.  

Scenes are comprised of different sources, so what actually exists in your scene is a number of 

different sources that you can control in their individual properties. A little bit of exploration will 

reveal many helpful features.  

Figure 2 

The main sources that you will need for any live lecture session will be available by pressing the 

“+” button. When you press it a dropdown menu will appear with all the different sources that 

you can play around with. These are very straightforward and meant to be very easily accessible 
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so even if you do not have experience with broadcasting 

software these sources should be very easy to set up. A 

list of all sources available in OBS are shown in Figure 3 

below.  

The main sources that you will need for every single 

lecture session that you do will be audio input capture 

and video capture device. These inputs are how OBS gets 

access to your microphone or webcam for the lecture 

session. If you choose to use external recording 

equipment, such as a camcorder or an external 

microphone, these inputs will need to be set up 

individually as well.  

Here is some brief information on some useful sources: 

1. Audio Input Capture allows you to hook up a microphone to OBS. The benefit of setting up 

your microphone in OBS is that you can add audio filters in the properties settings, 

including pitch, gain, compression and others to help make your lecture audio crystal clear 

and improve engagement. The video capture device will automatically connect with your 

laptops microphone as well.  

2. Audio Output Capture is what will be used if you choose to set up virtual audio cables 

between OBS and your streaming platform. The downfall of that is that you then need to 

set up virtual audio cables, which you have to pay for, and the process for that can be a bit 

tricky.   

3. Browser Source is a very useful tool which can let you capture any browser window. All 

you need to do to set up the source is to enter the URL for the tab that you want projected 

through OBS for that particular scene, set your resolution to 1920x1080, make sure you 

are streaming at 30 FPS (frames per second) and delete the custom CSS code in the text 

box. After you take these steps, rearrange the browser size on your scene preview window 

and you are ready to go. If you want to use the browser source while streaming live, simply 
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change to the browser scene that you have set up, right click on the browser in the preview 

mode, and press interact. A window will now pop up with only that website shown and you 

can now interact with while live streaming your lectures. Any sound from the browser 

window will get redirected automatically through OBS into Zoom. 

4. Display Capture takes a live screenshot of your entire screen and everything on it. Not a 

particularly versatile source and you can only have one display capture in your scenes, so 

if you are currently using the display capture in a scene and wish to set up another scene 

with a display capture, make sure to select add existing. 

5. Image or Image Slide Show allow you to add one or more images into a scene. Once you 

add the image you can resize and it and organize it however you’d like on your preview 

mode window. Image Slide Show will let you select a group of images or a file directory 

where a group of images resides and create a slideshow of images that you can flip through 

with the press of a key. You can adjust how long each slide can be visible for and whether 

or not the slideshow restarts or picks up where it left off if you change scenes halfway 

through. You can use the Image Slide Show source for displaying course slides while still 

getting the functionalities of OBS in your live lecture. If you use a LightBoard or a black 

background in your home studio, you can even add a chromakey filter, which lets you 

remove the background from slides (like a green screen) and allow you to interact with 

them seamlessly.  

6. Media Source will let you add any mp3 or mp4 video source into your OBS scene. Helpful 

if you show short informational videos during lectures, because you can integrate them 

straight into your OBS scenes. 

7. Scene is one of the most useful sources that OBS offers. It lets you use a preestablished 

scene as a source in your new scene. This is helpful if you want to reuse certain source 

setups that you already have and alter them or add to them in a new scene. It removes a 

lot of repetitive work setting up your cameras over and over again. 

8. Text is also a very ubiquitous source. OBS allows you to alter font, text colour, and even 

add transitions to increase the appeal of your lecture content.  



~ 9 ~ 
 

9. Video Capture Device is another essential source. This will hook up your laptops webcam 

or external camcorder with OBS. You can alter your picture settings here as well, including 

brightness, contrast, saturation, gamma, and even do a bit of colour correction if need be. 

This is all available by right clicking the filters button. Once there you will be able to add a 

bunch of different video filters.  

10. Window Capture is another extremely useful tool in OBS. It can allow you capture any of 

the windows open in your laptop at that moment, including file folders, documents, and 

even chat windows from Zoom and Teams. Make sure that when you set it up, the capture 

mode is automatic, and the correct window is selected. 

Setting Up Scenes in OBS 

The first step to setting up your first scene in OBS is to add a video capture device, which will also 

allow you select which video and audio input devices you want to use, be it your laptops built in 

webcam and microphone or external mics and camcorders. You can adjust resolution, buffer 

speed and how many FPS your video capture device will be outputting. You can also add filters by 

right clicking on the video capture device, in which you can colour correct your cameras output, 

which is helpful to produce lively looking lecture videos. These features are shown in Figure 4 & 5. 

 

 

 

 

 



~ 10 ~ 
 

 

 

Figure 4: Video Properties                                                               Figure 5: Video Filters 

You can also transform your image by right clicking on the video capture device and going to 

transform. Here you can flip your image horizontally so the image looks more natural to you as a 

presenter and to the audience.  

After your video and audio is set up, the next step is to create any subsequent scenes that you 

may need by copying the “Main” scene that you have just created with the video and audio already 

set up and then adding to it.  

Setting Up to Streaming Platforms 

To connect OBS with Zoom: 

1. Go under Tools -> Virtual Cam and select OBS Camera (the first one). Keep buffered frames 

to “0” so you have minimal time delay and keep horizontal flip unchecked. It is best to 

control horizontal flip in each scene individually than in the Virtual Camera.  

2. Open Zoom’s video settings and as an input device, select OBS Camera. This will redirect 

everything from OBS’s program view directly into Zoom. Keep your audio settings 
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connected to your laptops microphone in Zoom, unless if you choose to purchase Virtual 

Audio Cables.  

3. If you notice that text in your scenes is being shown backwards, you may need to go into 

OBS and select Tools -> Virtual Cam and select horizontal flip. That should fix any issues. If 

you find that your webcam video is flipped as well, you may need to right click on the Video 

Capture Device, select Transform, and click Flip Horizontal.  

 

To connect OBS with Teams: 

1. Go under Tools -> Virtual Cam and select OBS Camera (the first one). Keep buffered frames 

to “0” so you have minimal time delay and keep horizontal flip unchecked. It is best to 

control horizontal flip in each scene individually than in the Virtual Camera. 

2. Start a meeting in Teams and click on show device settings. Then select your OBS camera 

as the video input. Keep your audio settings connected to your laptops microphone. 

3. If you notice that text in your scenes is being shown backwards, you may need to go into 

OBS and select Tools -> Virtual Cam and select horizontal flip. That should fix any issues. If 

you find that your webcam video is flipped as well, you may need to right click on the Video 

Capture Device, select Transform, and click Flip Horizontal.  

Adding Chat Window to OBS Screen 

To add chat window to OBS: 

1. Go to Zoom or Teams and open the chat box. 

2. Select open chat in separate window (or Pop Out).  

3. Open OBS and add a window capture source in one of your scenes. 

4. Select the Zoom or Teams chat window. Make sure to click refresh when scene is 

reactivated. This will continually refresh the chat window and keep it live so you can answer 

student questions as they come up. 

5. Rearrange the chat window so that it doesn’t interfere with your webcam footage or any 

other elements on your screen. 
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Integrating Live Polling in Lecture 

Live polling is an excellent way to create deeper lecture engagement and test student 

understanding of topics. There are many different live polling software that you can use, and each 

has its own unique capabilities. Zoom live polling is a built-in feature for Zoom calls where the host 

can set up ahead of time a series of multiple choice or true and false questions that you can release 

throughout the lecture. Setting these up is very straightforward and can be done when the 

meeting time is scheduled by the host. You can also show a live window capture of the quiz results 

in OBS that allow the class to see the general consensus or perhaps change their answer. To 

accomplish this window capture in zoom, use the exact same steps that you used above for adding 

chat windows on screen.  

However, if you wish to use the results for class participation or grading, Zoom does not allow you 

to export quiz data into Excel for analysis of attendance or engagement. Another software that 

you can use is called Sli.do. It has many of the same capabilities of Zoom live polling but also has 

many different types of quizzes that you can do and also allows you to export data into Excel. This 

is a great alternative for any teachers who wish to use Teams or other lecture streaming platforms. 

To use all you have to do is make the quiz live and students can answer questions on their phone 

or on their laptops by entering a quiz room ID number. Sli.do has a free version where you can ask 

a maximum of 3 questions per session, or you can opt for the paid version which gives you 

unlimited questions and question types. There is an educator discount as well, if you do choose to 

purchase a license. Additionally, there are hundreds of different live polling software out there, 

and you can select anyone which suits your needs. The method to integrate the live polling into 

OBS remains as simple as setting up a scene with a window capture as a source.  
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Setting Up Hotkeys 

Hotkeys are a unique feature in OBS that allow you to automate your scene transitions within OBS 

to make your online lecture experience seamless and streamlined. It involves setting up certain 

keyboard shortcuts that allow you to change within scenes, change slides in an image slideshow 

as we will soon learn, or really do anything it is you want. Follow the steps below to set up any 

hotkey: 

1. Open settings in the right-hand tab on the screen and select hotkeys from the menu on 

the left side of the window.  

2. Hotkeys will show you all the different scenes and sources you have set up, so you can 

create transition shortcuts or any quick keyboard commands. Figure 6 below shows you 

the hotkey settings window.  

 

 

 

 

 

 

 

 

Figure 6: Hotkey 

set up window. 
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3. To add a hotkey, select the black bar next to any command and press the key that you want 

to use as the shortcut. Since OBS may be running in your background at any given moment, 

it is better to use an arbitrary keyboard shortcut that you wouldn’t otherwise use on a daily 

basis. For example, to transition between scenes it wouldn’t be wise to use something as 

ubiquitous as ctrl+c, but a command like alt+c would be useful. Alt is very uncommonly 

used in keyboard shortcuts so setting up a hotkey with “alt+” anything is probably the best 

way to go.  

4. If you accidentally enter the wrong key, you can use the trash icon on the right to delete it 

and start over.  

5. Since you may set up many hotkeys for your OBS functions, it is a good idea to write down 

a guide to what hotkeys you are using and what their purpose is. This can help you on your 

first few tries to remember the shortcuts quickly.  

The process to setting up hotkeys is really that simple. It is also very customizable and can be 

established to reflect your individual method of computer interaction.  

 

Showing Lecture Slides with “Green Screen” 

One of the most creative uses of OBS is to show lecture slides on your screen but with transparent 

backgrounds. Having your webcam video capture on the same screen as the slides in a smooth, 

continuous image improves student engagement much more than if you simply voiceover a 

PowerPoint. It creates a human connection and makes the online learning experience far more 

synchronous and capturing. Additionally, if you have purchased a LightBoard or plan on using the 

McMaster LightBoard studio spaces, having “green screen” slides with transparent backgrounds 

allows you to interact with your lecture content live, by highlighting certain key points, 

embellishing on your text or even by solving a lecture example right on the screen itself. The uses 

of this simple process are endless.  
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There are two main steps to showing your lecture content on your OBS screen. The first is to edit 

your lecture slides in PowerPoint to make them “green screen” friendly. To do this, following the 

steps below: 

1. Open your lecture slides on PowerPoint. If you are using Google Slides to make your lecture 

content, download the slides as a .pptx file. Make sure the formatting is how you want it 

because downloading it as a PowerPoint may shift around your text and images a little. 

2. Go to View -> Slide Master. Click on the very first slide on the left-hand side. It should be 

the biggest one as well. 

3. Select Background Styles and in the drop-down menu, click on Format Background. A side 

menu should pop up. From there, select Solid Fill and edit the colour to green (under the 

Standard Colours, there should be two shades of green: a light green and a dark green. 

Click the dark green). This will help us when we try to remove the background from OBS 

later. 

4. After making the above changes, go out of the background formatter and select Colours. 

Then click on Default Design 1. This should make all of your text white. If it isn’t pure white, 

you can also just do this manually.  

5. Now press Close Master View. 

 

 

 

 

 

 

Figure 7: We will be removing the 

background from this graph. 
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Now all of your text should be white and your backgrounds should be green. This will make it so 

that only your white text will show up against the black backdrop of the LightBoard studio. If you 

are doing your lectures at home or aren’t using a LightBoard, you can still take advantage of this 

feature by just creating a solid colour backdrop wherever you will be broadcasting from in your 

home and set the text to a colour that will show up best against that background.  

Another step that you can optionally take is to remove the backgrounds from any charts or images 

that you have in your lectures. This process is a lot more finnicky and you may have to play around 

with it based on the image you are working with. An image with one solid background colour and 

black lines is easy to format to “green screen” friendly mode, but if it’s a complex image or a real 

life photograph, you are better off just leaving that as it is. 

To remove the background colour from an image or a chart, follow the steps below: 

1. Select the image that you want to work on. For an example, I will be using the slide shown 

in Figure 6 below.  

2. Select the picture in PowerPoint that you want to edit and a red button on the tool bar 

above should show up, called picture format. Select this button. 

3. Go under Colour and at the bottom of the drop-down menu, select Set Transparent Colour. 

Click on the background of colour of the image, in this case the beige.  

 

 

 

  

 

 

Figure 8: Select set transparent 

colour and click on the beige 

background. 
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4. After having selected the background as a transparent colour, your entire graph should be 

completely invisible. Now all that will remain is the black lines of the graph itself. However, 

the black lines won’t show up on your background (depending on what your webcam’s 

backdrop colour is). To change the black lines to white, select Colour and select Washout 

(under Recolour, the first row, 4th from the left). 

 

 

 

 

 

 

 

Figure 8: Once you select Washout, your 

graph lines should become white.  

 

Once all of your slides have been formatted to your liking, create a separate folder for the lecture 

slides, and save your PowerPoint as PNG images (portable network graphics). This is the preferred 

file format for the chroma key “green screen” process. As mentioned, this process can change very 

easily based on what your lecture set up is and what images you are using, so a little 

experimentation may be required, but that is the fun part! 

An important issue you may have to deal with is that slides are numbered from 1 to n. However, 

after slide 1 OBS will automatically play slide 10, as alphabetically this is what technically comes 

next. To solve this issue you may need to rename your slides as “a, b, c…” and so on, and after 

slide 26 you can use “a1, b1, c1…”. This seems to solve the issue, though it can get tedious.  
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After this stage, all there is left to do is to set up an OBS scene with your lecture images as a source 

and then apply the chroma key filter which will remove the green background, effectively acting 

as a green screen.  

To do this, follow the steps below: 

1. Open OBS and create a new scene. Name it as “Lecture Slides Chroma Key”. 

2. In the sources tab, press the “+” icon and select Image Slide Show.  

3. For visibility behaviour¸ select Pause when not visible, unpause when visible. This will make 

sure that if you change your scene, the slides will not carry on changing and that you will 

be able to pick up right where you left off.  

4. For slide mode, select Manual (use hotkeys to control slideshow). This will allow you to 

change your slides whenever you want instead of having it be timed. What you want to do 

is go into settings -> hotkeys and then scroll down until you find image slide show. For the 

next slide and previous slide hotkeys, set alt+forward arrow and alt+backwards arrow as 

the controls (you can use other keys as well, but these are the most intuitive). 

5. You can also now change your transitions, and you have an option between fade, slide and 

cut. You can also adjust how long each transition lasts. Keep aspect ratio automatic and all 

other boxes unchecked. 

6. To the right of the image files box, there should be a plus arrow. When you click on it, it 

will give you the option to choose an image or a directory. Select add directory.  

7. Select the file folder where your slide images were saved earlier and press ok.  

Now that the slides source has been set up, we can remove the background colour by adding a 

chroma key filter. To do this: 

1. Right click on the image slide show under sources and select Filters.  

2. At the bottom left hand corner, there should be a “+” icon. Select it and click on chroma 

key from the drop-down menu that appears.  

3. The key colour type default should be green, and use the similarity, smoothness and 

opacity sliders to remove the maximum amount of green that you can from your slides. 

Then, press close.  
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You can now rearrange and resize your lecture content window. If you are using a LightBoard, 

make sure your webcam source is taking up the full screen and “behind” the image slide show 

source.  

Streaming with LightBoard 

LightBoard is an online teaching device used by many professors and online educational content 

creators around the world. It consists of a large pane of glass or Plexiglas framed by aluminum 

tubing which can be written on and the image reversed to produce a learning experience where 

visual information can be displayed while still maintaining human connection. It essentially is a 

chalkboard but in the reverse perspective. These can be purchased from the LightBoard Depot, a 

start-up founded by former McMaster engineering students.  

The set up to using a LightBoard is quite straightforward and the only essentials are the LightBoard 

(obviously), a camera/microphone, a table, and a black backdrop. The backdrop can be simply 

fabric taped to the wall behind you. The last important aspect to creating a good LightBoard 

presentation experience is adequate lighting, both on the board and on you as a presenter. If 

lighting is too dim, then your presence won’t be captured and the image will be grainy, but if it’s 

too bright then the marker won’t be visible on the LightBoard itself. This is a novel issue and is 

specific to the room that you are setting up your personal LightBoard in, but simple adjustments 

here and there can be more than enough to fix this problem.  

The only step in OBS to using a personal LightBoard is to make sure that the input from your 

camera is horizontally flipped. To do this, simply right click on your video capture device source, 

go under transform, and select flip horizontally. Now when you write it will be legible to your 

audience. Using the LightBoard in McMaster’s studio spaces is even simpler. The Faculty of 

Engineering and BTech studio spaces have the lighting, backdrop, audio/video and OBS already set 

up. All you need to do is go in and press the big red button to start recording. 


